I have just noticed this:

There are links in there, clickable and everything but not shown due to the site theme.

It should be something like this: (taken from different site in the network)

Can the color become cross-site please?

Edit: 10 months later, and it's still buggy and ugly:

Is this really that hard to fix?!

share
2  
6 months and it's STILL not fixed.. What a shame. –  user11153 Jul 25 at 21:33
1  
@user11153 totally agree, I know for sure it's on the team's To Do List, but looks like it's in the very bottom of it. So it might take years. –  Shadow Wizard Jul 25 at 23:04
    
Just came here to post the same thing myself. Here's my screenshot: i.stack.imgur.com/BOK1N.png. –  TRiG Dec 10 at 19:10
    
@TRiG yeah, it happens with all of them. You double posted by the way, please delete one of the comments. –  Shadow Wizard Dec 10 at 20:09

1 Answer 1

This is actually a CSS specificity issue. The links are styled to be non-black with the following CSS rule:

.ad-container a, .ad-container a:visited {
    color: #EAD29A;
}

but this rule is overridden by the (formally) more specific rule:

#sidebar a, .sidebar a {
    color: #000;
}

because an #id selector counts as more specific than a .class selector.


To fix this, the first CSS rule above should be rewritten to something more specific, such as:

#sidebar .ad-container a, #sidebar .ad-container a:visited {
    color: #EAD29A;
}

Ps. I've included this fix in SOUP v1.10. It's currently applied only to skeptics.SE, since other sites may style their ad links differently. If you encounter this bug on any other SE sites, please let me know.

share

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .